Jump to content

1212 - 1819 - DateTime Original seconds = 00 deleted


Uwe
 Share

Recommended Posts

Hello,

 

the value of the seconds of the DateTime Original = 00, e.g. Date/Time Original 2015:05:02 13:11:00

Then I entered a keyword and a collecion tag and saved the changes.

This is the result: Date/Time Original 2015:05:02 13:11:

Tested with a DNG file.

You got a download link with a video and the image file.

 

Regards, Uwe

Link to comment
Share on other sites

Hello,

 

the value of the seconds of the DateTime Original = 00, e.g. Date/Time Original 2015:05:02 13:11:00

Then I entered a keyword and a collecion tag and saved the changes.

This is the result: Date/Time Original 2015:05:02 13:11:

Tested with a DNG file.

You got a download link with a video and the image file.

 

Regards, Uwe

 

Uwe:

 

The same thing happens to JPG and TIF files also.

 

It seems to me that the problem occurs when Daminion writes a time/date stamp to Exif:ModifyDate. As long as Exif:ModifyDate has an entry, I can't get the final "00" to be written. I have tried using exiftool and the ExifToolGUI tool to write this field. When the Exif:ModifyDate field is emptied, I can then write the final "00" back.

 

If I use the ExifToolGUI tool to write a date/time stamp to the Exif:ModifyDate field, I don't seem to have a problem with the final "00" being removed.

 

Hope that makes sense.

 

Frank Hahn

Link to comment
Share on other sites

Hello,

if that happens,

1. enter "01" in the seconds field in the tag Creation DateTime in the Properties Panel

2. Save

3. enter "00" in the seconds field in the tag Creation DateTime in the Properties Panel

4. Save

Daminion doesn't have a problem with the missing seconds data but Geosetter doesn't work without a full DateTime Original data.

Regards, Uwe

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 months later...
  • 4 months later...
  • 1 month later...

I have a lot of files from scans of negatives. I used exiftool to add the DateTimeOriginal and CreateDate fields.

 

I stamped a lot of the files with an approximate time and date. For example 1985:06:01 12:00:00 (June 01, 1985).

 

What I have seen get truncated after Daminion modifies the file are the DateTimeOriginal and CreateDate fields. Once I edit and add metadata to a file, the ending 00 gets truncated.

 

These fields should look like this:

1985:06:01 12:00:00

but look like this:

1985:06:01 12:00:

 

One thing I have noticed is that as long as Exif:ModifyDate has a time stamp, you can't add back the ending seconds (00). Once this field is empty, you can.

 

Another software program that I use to look at and modify these fields is ExifToolGui. It is a front end to exiftool.

 

Frank Hahn

Link to comment
Share on other sites

  • 3 weeks later...
  • 4 weeks later...
  • 1 month later...
  • 1 month later...
  • 1 month later...
  • 4 months later...
  • 1 year later...

Hello,

this bug is still there in build 1765.

Regards, Uwe

Update: I made a test with a scanned TIF file

1. after the scan there is no DateTime Original in the metadata of the file

2. Import by Rescan folders - still no DateTime Original in the metadata of the file but in the Properties Panel is shown the DateTime of the import

3. Enter Creation DateTime 12:00:00 in the Properties Panel and a Title tag, e.g. "test" -> DateTime Original in the metadata of the file is ok: 12:00:00

4. remove the item from catalog and delete the file from folder

5. Repeat step 2

5. Enter Creation DateTime 12:00:00 in the Properties Panel, a Title tag, e.g. "test" AND Keyword tags, e.g. "original", "scanner" -> DateTime Original in the metadata of the file is not ok: 12:00:

Link to comment
Share on other sites

  • 3 weeks later...

+1

 

When can we expect this to be fixed please?

 

It's a tiny bug, but creates problems orders of magnitude greater. Because of this problem, Synology Moments cannot sort the files correctly, and uses date scanned instead of Date Time Original

 

Three years seems an excessive wait for a simple fix

 

Paul

  • Upvote 1
Link to comment
Share on other sites

Hi guys,

 

My apologies for such tremendous delay! I will ask the guys is this is possible to fix it in the upcoming 5.9 version

 

Kind regards,

Daria

 

That's great news. Look forward to that.

 

A supplementary question arises. Once we know that the issue has been solved in all new date handling, how will we find and repair the broken ones please? Or will it just be a case of writing all tags to file for all images in the library? I'd like a script that could find all files with MM or SS = null. Could exiftool do that?

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...