Jump to content

Keywords not saved to jpg file


Recommended Posts

I've just discovered that keywords, and geotags, are not being written to the jpg metadata. I hit the save (write to file) and it looks like it has saved but when I read from file the keyword disappears. I can write tags with other software and they read ok with Daminion 6.8. I'm not seeing any errors.

Link to post
Share on other sites

I write the keyword, save it or sync it, then read it back again from the file. I first noticed it after geotagging files and then checking them in another program and I was puzzled why they didn't show up. Further investigating revealed that keywords weren't saving either. I've rebooted and tried a few things. If I restart Daminion it shows them as there but if I read the metadata from the file they disappear ūüėě

Link to post
Share on other sites
14 minutes ago, Peter S said:

I hit the save (write to file)

Peter please note, clicking Save in the properties panel, does not save the tags to the image file. It rather saves the changes on screen into the database. Writing tags into metadata is done by Image->Actions-Write Tags to file.

If nothing happens with Image->Actions-Write Tags to file, there might be a lock or insufficient authorities, if they are on a network drive.

Link to post
Share on other sites

Yes I've done that as well using the read and write under the Sync drop down menu. It is quite puzzling. I've tried it on different jpg photos as well and get the same problem. I can write keywords/tags using other software and read it with Daminion. I just can't get writes to the jpg with Daminion. It worked in the past but I haven't don't recently with Daminion.

Link to post
Share on other sites
2 minutes ago, Peter S said:

It worked in the past but I haven't don't recently with Daminion.

What version of Daminion are using? Standalone or Server? If you use the server version, which Windows user is defined in Daminion Administrator?

Link to post
Share on other sites
4 minutes ago, Peter S said:

standalone

I don't remember, where exactly the logs are written for the standalone client. Just have a look, if you do find this folder: C:\ProgramData\Daminion Software\Daminion Server\Logs . Possibly  the Logs folder is not under Daminion Server, but certainly somewhere under C:\ProgramData\Daminion Software . Remember the exact time, when you tried to write to file and search the logs for that.

Link to post
Share on other sites

Nothing in the log in here, 0 bytes in size.

I checked writing the keyword on two different jpgs. An old one from a Canon camera and one from my Pixel 3 phone. I had the same problem on both.

The file is not read only or hidden. I can write to it with other DAM software.

Link to post
Share on other sites

Coincidentally, I made changes this morning as advised by Daria but for another problem. I doubt it would cause a problem?

1. C:\Users\USER_NAME\AppData\Roaming\Daminion Software\Daminion\1.0
2. Open the file "Settings.xml"
3. Find the string "<setting name="RestoreSorting" serializeAs="String"> "
4. You need to edit this string to get the following result:
<setting name="RestoreSorting" serializeAs="String">
<value>True</value>
</setting>
5. Save changes
6. Restart Daminion. The sorting order will be preserved between sessions now.

Link to post
Share on other sites
48 minutes ago, Peter S said:

I made changes this morning

Peter, do you have a backup of settings.xml, as it was before? Even though, I think it is unlikely, a typo might have changed something badly ...

50 minutes ago, Peter S said:

The file is not read only or hidden.

Did you verify all the folders where the images reside in? The fact that other software can write, sounds strange though.

Link to post
Share on other sites
3 hours ago, Len said:

where do I find that Option on Daminion Standalone please

There are two ways Len,

  • Select one or more images, right click one of those, from the context menu select Actions -> Write Tags to file (or faster: right click-> a -> w )
    grafik.thumb.png.9890541f15bf9bed96eced991c5cc483.png
     
  • Alternatively you can use the main menu: Item -> Actions-> Write Tags to file.

 

 

Link to post
Share on other sites

I ran Daminion as administrator and it then worked fine. I could write the tags/keywords ok. I then checked the file permissions and found that the directories were all Read Only! I tried to change them back to normal but even as the administrator this didn't work. I'm now trying to work out why Window 10 has done this. I then tried to write out all 40,000 tags, just in case there are some unwritten, and I got this error message. I did write out to 3,000 photos and this worked. Maybe there was just too many writes to the entire catalog.

//See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Code: -1
Message: Object reference not set to an instance of an object.
Server-side Stack Trace:    at PicaJet.Daminion.Service.Utils.CreateMediaItemsBookCommand.ProccessSet(ICriteriaList criteriaList, IList`1 props) in C:\DaminionAutoGit\code\Service.Utils.Uni\Command\CreateMediaItemsBookCommand.cs:line 83
   at PicaJet.Daminion.Service.Utils.CreateMediaItemsBookCommand.Treat(DbConnection connection) in C:\DaminionAutoGit\code\Service.Utils.Uni\Command\CreateMediaItemsBookCommand.cs:line 125
   at PicaJet.Daminion.Service.Utils.DatabaseCommandWithResult`1.Start(DbConnection connection) in C:\DaminionAutoGit\code\Service.Utils.Uni\Command\DatabaseCommandWIthResult.cs:line 32
   at PicaJet.Daminion.Service.Utils.DatabaseCommand.Start() in C:\DaminionAutoGit\code\Service.Utils.Uni\DatabaseCommand.cs:line 102
   at PicaJet.Daminion.Service.Utils.DatabaseCommand.Process() in C:\DaminionAutoGit\code\Service.Utils.Uni\DatabaseCommand.cs:line 50
   at PicaJet.Daminion.Common.OperationResult`1.get_Data()
   at PicaJet.Daminion.ClientCommon.CloudSynchronizeManager.SearchAllItemsIds(IBaseCatalogService service, ICriteriaList stack, CriteriaSet propSet, EventHandler`1 callback) in C:\DaminionAutoGit\code\ClientCommon\Classes\CloudsServices\CloudSynchronizeManager.cs:line 654
   at PicaJet.Daminion.ClientCommon.PicaJetEnginePresenter.ReadWriteMetadata(Boolean write, IMediaItem mediaItem) in C:\DaminionAutoGit\code\ClientCommon\Presenters\PicaJetEnginePresenterActions.cs:line 3638
   at PicaJet.Daminion.ClientCommon.PicaJetEnginePresenter.WriteMetadata(Object sender, ActionExecuteEventArgs e) in C:\DaminionAutoGit\code\ClientCommon\Presenters\PicaJetEnginePresenterActions.cs:line 3576
   at PicaJet.Daminion.ClientCommon.Action.ExecuteAction(Object sender, ActionExecuteEventArgs e) in C:\DaminionAutoGit\code\ClientCommon\Classes\Action.cs:line 397
   at PicaJet.Daminion.ClientCommon.PicaJetEnginePresenter.SynchronizeActionManagerLaunchActionByName(Object sender, ObjEventArgs`1 e) in C:\DaminionAutoGit\code\ClientCommon\Presenters\PicaJetEnginePresenterActions.cs:line 2267
   at PicaJet.Daminion.ClientCommon.SynchronizeActionManager.DoLaunchActionByName(String actionName) in C:\DaminionAutoGit\code\ClientCommon\Actions\SynchronizeActionManager.cs:line 107
   at PicaJet.Daminion.ClientCommon.SynchronizeActionManager.WriteMetadataAction(Object sender, ActionExecuteEventArgs e) in C:\DaminionAutoGit\code\ClientCommon\Actions\SynchronizeActionManager.cs:line 95
   at PicaJet.Daminion.ClientCommon.Action.ExecuteAction(Object sender, ActionExecuteEventArgs e) in C:\DaminionAutoGit\code\ClientCommon\Classes\Action.cs:line 397
   at PicaJet.Daminion.GUIComponents.ContextMenuGenerator.MainMenuItemClick(Object sender, EventArgs e) in C:\DaminionAutoGit\code\GUIComponents\Classes\ContextMenuGenerator.cs:line 595
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)//

...

//----------------------------------------
CustomMarshalers
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/CustomMarshalers/v4.0_4.0.0.0__b03f5f7f11d50a3a/CustomMarshalers.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box//

Maybe I'll just have to rebuild the Daminion catalog.

 

 

Link to post
Share on other sites
5 minutes ago, Peter S said:

'm now trying to work out why Window 10 has done this.

How did you copy the images onto your computer? If I remember correctly, this might happen, if you copy a complete folder from an SD card to your HDD. 

 

7 minutes ago, Peter S said:

Maybe I'll just have to rebuild the Daminion catalog.

I doubt this would help. The problem are the folders your images are stored in - not the Daminion catalog.

Link to post
Share on other sites

The actual jpg files are not read only but the directories are. The Daminion catalog is in a Read Only directory. I copied all the photos off a USB drive. Not sure why Windows won't let me change them all to normal directories. I'll have to read up on how to make them all normal directories as each time I set them back to normal they stay as read only.

Link to post
Share on other sites
3 minutes ago, Peter S said:

Not sure why Windows won't let me change them all to normal directories.

Peter, maybe this helps: "If your folder keeps reverting to read-only it could be due to a recent Windows 10 upgrade. Many users have reported that when upgraded their system to Windows 10, they encountered this error." https://appuals.com/how-to-fix-folder-keeps-reverting-to-read-only-on-windows-10/

Link to post
Share on other sites

Thanks for the link. I tried them all but the folders still show as Read Only (even after a reboot), however, I can now write keywords out ok which is good when I run it as my normal user. I'll have to keep an eye on it and do some more research to see why the directories are remaining as "Read Only".

  • Like 1
Link to post
Share on other sites
  • 3 months later...

Hi, i have the same problem but when i try to launch Daminion as Administrator, my network drives desapear and are not seen by Daminion.  It is then impossible to write the tags in the files which are no longer seen by Daminion

Link to post
Share on other sites
2 hours ago, F.B. said:

my network drives desapear and are not seen by Daminion

Please have a look at this post (844) rights Problem, possibly Uwe's response can solve your problem.

I don't remember what exactly was the problem in my case, but I also hat to enter "user" and the password instead of using "local System account".

Link to post
Share on other sites

I can (painfully) report the same issue. Also Daminion Standalone 6.8 on Windows 10, also no errors visible. I was not able to write the tags to the files until I opened Daminion as administrator. 

- I checked read/write rights to pictures, daminion catalog and all related folders. They are ok and showing full read/write rights. 

- As reported here by Peter S, when hitting "Write Tegs to File" there is no message, everything seem fine, but after checking metadata nothing is there. After hitting "Read Tags from File" all tags in Daminion catalog are gone.

- During the issue all pictures are indicated as synced. What is the purpose of this "sync" if its indicating OK while tags in file and in Daminion catalog are different?

The painful part is that due to this issue I probably lost 4 months of picture tagging. Yesterday I added few new pictures to the catalog (just by copy the in Windows). To update Daminion catalog with them I run the full catalog sync. After this half of my tags are gone! Both Daminion catalog and pictures metadata are not having tags. Back to the status of around 4 months ego. I suspect that issue of not writing to the files started around that time and full sync just "updated" Daminion catalog with tags from files (meaning no tags). Very, very, very annoying to say at least :(.

Questions I have:

¬†-What is the purpose of ‚ÄúSync pictures‚ÄĚ if its showing ‚Äúsynced‚ÄĚ even when pictures and Daminion catalog tags are different?

- Is there any way I can retrieve my tags? Last Daminion catalog backup is also from 4 months ego and showing the same tag status as newly ‚Äúsynced‚ÄĚ catalog. Not sure if this is coinsident, perhaps around that time some event triggered the automated backup and did something to the Damionion to prevent it from writing tags to files?

- Do I need now always open Daminion as administrator to be able to write tags to files?  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...