Jump to content

[1934] Does not work under Windows 10 1903


Recommended Posts

Yesterday evening I did a fresh install of Windows 1903 on my Home PC.

I was not able to open my existing Daminion Catalogs or  create a new Catalog.

After starting Daminion I always get an error message with a missing .dll.

First I thought it is a problem with my Windows installation, but today  I performed an Update to W10 1903 on my Notebook and tried to install Daminion and I get the same error message.

Can you please have a look at this issue because Daminion is not useable.

Can I switch Daminion to english in order to get the error message in english?



Link to comment
Share on other sites

On 5/28/2019 at 10:49 AM, xeta said:

Can I switch Daminion to english in order to get the error message in english?

I hope, we see a response from the Daminion team soon, but since the roll-out for 1903 just started and supposedly will be very slow, they might not even have a test environment .... But you didn't say, whether you use a stand-alone or a shared catalog on the server.
I can only respond to your last question: Yes, you can. To switch from German to English, select in the menu Ansicht-SpracheEnglish:



Link to comment
Share on other sites

I am running the Standalon Version, I thought that is clear because I posted in this certain forum.

In between I found the switch to change the language, the meesage says:

"Unable to initialize the native configuration support external to the web worker process (HRESULT=0x80040154). nativerd.dll must be in %windir%\system32\inetsrv"

Probably more users will run into this problem, a respond from the Team woulb be welcomed

Link to comment
Share on other sites

Did you look into folder %windir%\system32\inetsrv (normally = C:\WINDOWS\system32\inetsrv ), to see whether the file nativerd.dll is there? I found it on mine, but I am still on version 1809. Its change date is 15/09/2018 which probably means it was replaced when Windows Version 1809 was installed. If it does not exist on your system, it might be a bug in Windows 1903.

Link to comment
Share on other sites

11 minutes ago, WilfriedB said:

So, it is certainly a problem caused by the Windows update. I did a Google search for " nativerd.dll" and found several posts from the past, starting with XP and later, bust so far none specifically related to Windows 10 1903.

Most probably it is connected to Windows 10 1903 but however it would be interesting to hear any comments from the team because they know the dependencies

Link to comment
Share on other sites

5 minutes ago, xeta said:

it would be interesting to hear any comments from the team

I completely agree and to be honest, it worries me lot that we see comments from the Daminion team less and less frequently here in this forum. And you are right, this is an extremely important issue. Nevertheless, I wonder if anybody already migrated to Windows 10 1903 without having problems with Daminion. To me, this post means, I will not do the Windows update, untill I saw a solution here!

Having said that, don't forget, the forum is meant as media to exchange experiences between users, you should also report this problem directly to them.

Link to comment
Share on other sites


very interesting.

On my PCs the folder C:\WINDOWS\system32\inetsrv  is   empty.

I find the file nativerd.dll when searching with "Everything" (my most used program) in a collective (?)  file, which in my opinion is an archive file.
And Daminion is working.

Windows 10  Prof/Home  1809
Daminion Standalone





Link to comment
Share on other sites

  • 1 month later...

The setting to turn on HTTP Activation eliminated the issue for me too. I did not try the solution suggested on the linked page.

I am also on 1903 but am not sure that update is what caused it. Could be.

On the other hand, Daminion functioned well even though I had that error message. I only ignored it and it worked as usual.

But now I don't get the error message.

Thank you for the solution!

Link to comment
Share on other sites

  • 5 weeks later...
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...