Jump to content

Dates, dates and more dates


Paul Barrett
 Share

Recommended Posts

Is there an 'Exif Tool in Daminion' expert on this forum who could help me out please?

 

The back story:

I am a newbie to Daminion and I am already loving it, having suffered the nightmare of Adobe Lightroom and Photoshop Elements. Their tag management is smoke and mirrors, the horrors of which were exposed when I started to view the library through other apps such as Windows Photo and Synology Photostation and found that despite deleting redundant tags and exporting the metadata to file, Adobe do not overwrite tags, they append them.

 

So 15 years of of tagging, changes of mind, total revamps etc and every remnant of the old ways was 'lovingly' preserved in the metadata. I used Exif Tag Remover to clear the metadata and re-exported it from PSE, only to discover that Adobe preserves all the deleted tags in its database, suppresses them in its own interface (so you think they have gone) but exports them all to the metadata again.

 

So finding Daminion and sorting the tags out properly was wonderful.

 

I have one outstanding issue, and that is equalising dates.

 

Daminion does a good job of reading dates from multiple metadata sources (Exif, XMP etc) and mapping them to Daminion fields. But for reasons that I don't understand (I'm still new to this) doesn't seem to reverse the process when writing the metadata to file. This is important to me because I want to view the library through various apps all of which use different metadata fields for presenting the files.

 

To demonstrate an extreme example, I did Daminion updates across 13,000 images and so the file modified date was changed to 'today.' But Windows Photo uses the date modified to sort the images. Therefore every one of my images was shown as being 'todays' image when in fact the earliest of my library dates to 1904!!

 

I have used 'BulkFileChanger' and 'Exif Tool GUI' to sort out some of the problem but neither tool will let me update all of the various date fields scattered across the metadata, including the basic file info which Windows uses.

 

I suspect I might be able to use the Exif Tool version built into Daminion to map dates from one metadata field to another but when I try, I get error messages such the date and time format is incorrect, when it's quite clear from the metadata itself that the formats match (at least they look like they do to me).

 

All the Exif resources I have found so far are so technical that I haven't found a solution out there.

 

The fields I want to map TO are:

 

File Info:

  • File Modification Date/Time
  • File Creation Date/Time

Exif:

  • Create Date

IPTC

  • Date Created

Composite

  • Date/Time Created

- and the source field is :

Exif

  • Date/Time Original

I may be trying to do the impossible but I don't know what is possible.

 

Can anyone help me out please?

Link to comment
Share on other sites

Hello Paul,

1. in the server version there is an option to keep the File Modified Date of the Windows System.

20160924_174633.jpg

2. there is the option to call external programs. In your case e.g. the ExifTool: Right click on the item->Open with->Define External Tools...

Here are my current options:

20160924_175307.jpg

That means, if you change something with an external tool you have to import these settings by "Read Tags from File..." and the limitation is the external tool, in this case the ExifTool. But not all of the information of the Windows File System are relevant for Daminion

Regards, Uwe

Link to comment
Share on other sites

Thanks Uwe

1. Actually, the preference to Preserve File Modified Date is present in the desktop version too so I have just turned it on. That'll sort out the issue going forward but now I need to restore an approximation of the correct date on the 13k files in the catalogue. The previous modified dates are lost so the closest I can usefully get is to write the original date created back to the file modified date.

2. Yes, I saw the option to call external tools and I have enabled it an tried to use exif tool but I just don't know what the parameters would be to write the original creation date back to the modified date - is that even possible in exif tool?

3. Ah, I did not realise that you had to write the data back. On reflection it is bloody obvious. Doh!

So, I am still looking for help with the syntax for exif tool to use the fields specified in my OP.

Any takers please?

 

Link to comment
Share on other sites

Hi Paul,

 

According to ExifTool documentation following command should solve your problem

exiftool '-FileModifyDate<DateTimeOriginal' dir

Use the original date from the meta information to set the same file's filesystem modification date for all images in a directory.

 

You may need to add to the command also 'modifydate<DateTimeOriginal' if you want also change the timestamps in tags.

 

-Juha

 

:smile: No Warranty disclaimer, I haven't tested these. :smile:

 

-Juha

Link to comment
Share on other sites

Hi Juha

 

Thanks for your help. Unfortunately it did not work. I tried different formulations of the command both in the Exif Tool in Daminion and also using the ExifToolGUI external to Daminion. But no combination of commands worked in either tool. The error messages varied as I modified the command but were similar to this one

======== modifydate<DateTimeOriginal

======== {Filename}

======== ./FlorenceHackettAged19.tif

1 image files updated

2 files weren't updated due to errors

Warning: Error opening file - modifydate<DateTimeOriginal

Error: File not found - modifydate<DateTimeOriginal

Warning: Error opening file - {Filename}

Error: File not found - {Filename}

<-END-

I was running this against a single image so it's interesting that the error message said 1 image file was updated and 2 were not due to errors

 

So basically I am stuck. But thanks again. If you think of any other solutions I'd love to hear from you.smile.gif

 

Regards

 

 

Paul

Link to comment
Share on other sites

Hi,

 

I had an error in the command, the hyphen was missing from modifydate. Have you tried to run the command from command line (dir is the directory where your pictures are)

 

C:> exiftool '-FileModifyDate<DateTimeOriginal' '-modifydate<DateTimeOriginal' dir

 

The error message tells that ExifTool tried to change three files

= modifydate<DateTimeOriginal

= {Filename}

= ./FlorenceHackettAged19.tif

and succeeded only with the TIFF file. If you check the TIFFs modify date in Windows it should now be changed.

 

-Juha

Link to comment
Share on other sites

I have been playing around with the syntax etc, have had some limited success and I think I have found a bug in Daminion and another in ExifTool.

 

Issues I had to resolve before I could proceed:

 

1. Running cmd in Windows

I kept getting file access denied. I fixed that by right clicking the CMD app and running it as administrator

 

2. Where to execute the command.

After trial and error I found that the only place the command would execute successfully was if run from the same directory in which the exiftool.exe was located, in my case c:\Windows\Exiftool

3. Get the right type of quote marks to surround the arguments

You need to use " not ' - Thank you Daria

4. If your files are located on a network drive

You cannot address them by drive letter such as Y: you must use Universal Naming Convention (UNC) e.g. \\NAS02\ in my case. If you don't, you will get 'Cannot find files' errors

5. Omit the leading C:>

That just caused the command to abort. When I stripped it out (and did all the other things above) the command worked.

 

And now for the bad news.

1. Date Format:

Exif Tool failed to update a significant number of files due to an invalid date / time format. On investigation I found a discrepancy between the Creation Date Time in the Properties Panel in Daminion and the Date / Time Original field in the metadata.

For my historic photos where 'time taken' is unknown I set the original time in Daminion to midnight '00:00:00'. Unfortunately when Daminion writes that time to the metadata it writes it as ' : : ' When ExifTool sees that format it refuses to update the date and throws an 'invalid date / time format' error message. The only solution is to choose another time. if I add a second to the time then Daminion correctly writes it as '00:00:01' which solves the problem. So, how the heck do I find the hundreds of files scattered throughout my library and, even if I can find them, do I really have to amend them all individually?

 

One way to find them is to run the modify date command over each folder in turn and sift through the error messages - an exercise which just too daunting for words. Any suggestions please folks?

And now for the BIG one:

2. Which Century are we in?

When exiftool writes an original date / time to the File Modified Date it writes 1920 as 2020!

To check it wasn't an isolated case I tried images with dates of 1920 and 1904 - same problem.

You now what, 16 years after the event, I have just seen my FIRST year 2000 bug.

I fast forwarded to 1975 and tried it there. 1975 was written correctly.

So there is a tipping point, somewhere in the 20th Century.

Now what the **** do I do?

Link to comment
Share on other sites

So, I thought I would do a little community service and try to track down the tipping point in the 20th Century when Exiftool begins to have problems with dates and converts 19xx to 20xx - see my previous post.

My folders are organised by date so all I had to do was work backwards through the years.

 

I had already shown that 1975 was OK , so that was my starting point

 

I did not have to far before I encountered a problem, although this was an entirely new one. When I got to 1968 and ran the command, I got:

C:\Windows\ExifTool>exiftool "-FileModifyDate<DateTimeOriginal" "-modifydate<DateTimeOriginal" "\\nas02\photo\pictures\1968"

Warning: Cannot handle date (01, 00, 00, 30, 5, 1968) in File:FileModifyDate (ValueConvInv) - //nas02/photo/pictures/1968/Chris 3.jpg

Warning: Cannot handle date (01, 00, 00, 30, 5, 1968) in File:FileModifyDate (ValueConvInv) - //nas02/photo/pictures/1968/Chris 1.jpg

1 directories scanned

2 image files updated

Contrary to the last line of that message the files were not updated. If you look at the date 01 00 00 31 5 1968 it is the inverted form of my image - almost. My actual date is 30-06-1968 00:00:01. Not May, but June. I have NO idea where this came from. There is no 5 in any date field in the metadata.

 

I could see nothing different about the metadata formats for these two images compared to all the ones that had gone before.

Therefore I have no idea what this error message really means, and thus no way of fixing it.

 

I will continue going back through the years. Let's see what happens. I'll report back......

 

 

.... I got back to 1957 and the same date recognition error kept recurring so I gave up.

 

I don't know what to do now. To recap, 'all' I was trying to do was to equalise some dates. Anyone know of any other tools please?

------------------------------------------------------

Update 27 Sep 2016

I have been conversing with Phil Harvey on the Exiftool forum and it transpires that many of these date related issues are not Exiftool bugs but limitation on the underlying OS file systems. What I was trying to do was assign File Modified dates that predated the computer era. Well, no wonder it screwed up.mega_shok.gif

FYI: At the other extreme, Exiftool cannot handle dates beyond 2034

Link to comment
Share on other sites

Hello Paul,

 

regarding this topic:

 

"For my historic photos where 'time taken' is unknown I set the original time in Daminion to midnight '00:00:00'. Unfortunately when Daminion writes that time to the metadata it writes it as ' : : ' "

 

There is an already existing post

https://daminion.net/user-forum/index.php?/topic/2645-1212-1481-datetime-original-seconds-00-deleted/

 

I guess your problem belongs to same topic. We hope to get a solution as soon as possible from the Daminion developers.

 

Regards, Uwe

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...