Jump to content

Tagging - very slow performance


Quantaderp
 Share

Recommended Posts

Hi,

 

I've started using Daminion a few weeks ago and I'm really happy with the functionality. My only significant issue is with tagging. It takes about a second for all of an image's tags to load whenever I click on an image, and at least 1 or 2 seconds for a tag to be assigned. Is there any way to speed this up?

 

I'm running Vista 64 on a Core 2 Duo E8500 with 8GB of RAM and a 7200k RPM HDD. (Yeah, the system is ancient - I'll be surprised if it's due to the system, though, since fairly demanding applications like Photoshop run smoothly in nearly all scenarios.) If it's important, I have 6023 catalog items and around 100 tags, but I haven't seen performance vary with the amount of either.

Link to comment
Share on other sites

I figured out a solution, posting it here in case any other Vista users have this problem. :)

 

I disabled Indexing and Superfetch in Windows Services, that fixed the issue. Working with tags in Daminion now seems to be almost real-time, probably about 5-6x faster than before. Definitely enough for a comfortable experience.

 

Apparently Vista services sometimes really hammer hard drives, and that was what was happening to me. My hard drive was _constantly_ being indexed, so it's no surprise Daminion was really slow whenever it tried to read or write tags.

 

Here's the link to the solution I found, it contains the steps I followed. http://www.telegraph.co.uk/technology/advice/9074881/Why-is-my-hard-drive-always-whirring.html

Link to comment
Share on other sites

I use the home server version. It is used mainly by myself. I bought a second license in case my wife wants to access the database but so far, that has not happened very much. All she wants to do is search download files for various projects that she wants to work on using other programs.

 

I believe you can run the server version for 30 days so you can test it first to see if it works better for you.

 

Frank Hahn

Link to comment
Share on other sites

Quantaderp,

 

another option might be tweaking Vista's search indexer and some other settings; on my late Vista laptop reducing the number of locations being indexed worked quite well, making search fast and smooth and reducing drive activity. Here are some fine suggestions:

 

http://www.tweakguides.com/VA_5.html

 

You might want to read the whole article, it is not that long.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...