Jump to content

911 - wrong seconds in Creation DateTime


Uwe
 Share

Recommended Posts

Hello,

 

it seems, that Daminion doesn't write the full time information from the import source file in the destination file when the seconds value of the source file is "00".

 

I got the information in Geosetter that some files (DNG and JPG) don't have the date/time information when the photo was taken.

 

In Daminion the Creation DateTime (e.g. 5 December 2013 14:30:00) for both files seems to be ok.

But in the Metadata the "DateTime Original" and "Create Date" have these values:

Date/Time Original 2013:12:05 14:34:

Create Date 2013:12:05 14:34:

The seconds are missing. That leads to the error message in Geosetter.

 

The original source CR2 and JPG files have the full time information:

Date/Time Original 2013:12:05 14:34:00

Create Date 2013:12:05 14:34:00

 

There seems to be a bug in the time tranformation of the import process.

I changed the time in the Properties Window for the DNG and the JPG items to 14:34:01 -> this information is in the matadata of both files now.

Then I changed the time information back to 14:34:00 -> the time metadata of the DNG file is ok now: 14:34:00. But in the JPG the time metadata is wrong again: 14:34:

 

I'll send example files (original and renamed by Daminion, and a video) to you by email.

 

Regards, Uwe

Link to comment
Share on other sites

  • 3 months later...

Hello,

 

this bug is back.

The second information of DateTimeOriginal is missing in the DNG file when the seconds value in the source file is "00". See explanation above in the initial post. Create Date is ok. See screenshot please.

I've scanned a little bit more my files and have this problem with other media formats of images too (TIF, JPG).

Tested with shared catalog. I didn't want to open a new post.

 

Daminiopn_998_wrong_DateTimeOriginal.JPG

 

Regards, Uwe

Link to comment
Share on other sites

I can't reproduce this issue. Can you please record me a short video with the following steps:

 

- Set some date to an image with 00 seconds

- Actions > Write Tags To Images

- Actions > Show All Metadata

 

And please show me also the "Preferences > Writing Metadate" window

Link to comment
Share on other sites

  • 5 months later...

I posted a topic on this a few days ago because I did not see this thread.

 

I was thinking it just affected my TIFF files but after seeing this, I started looking for JPG files that might be affected and it looks like I have a lot of them that have the seconds truncated in the DateTimeOriginal and CreateDate fields.

 

I spent yesterday trying to fix all of the TIFF files that have been affected. Right now, I don't know how many JPG files are affected or how long it may take to fix this.

 

Frank Hahn

Link to comment
Share on other sites

  • 6 months later...

This is still an issue. I am using Daminion version 3.7 (1187).

 

Like has been mentioned earlier, any files that have time ending in :00 gets truncated after Daminion modifies the file.

 

The metadata fields that I see get truncated are DateTimeOriginal and CreateDate.

 

One thing I have noticed is that as long as Exif:ModifyDate has a time stamp, you can't add back the ending seconds (00). Once this field is empty, you can.

 

The software that I use to look at and modify these fields is ExifToolGui. It is a front end to exiftool. I keep exiftool updated and I see the same results after Daminion modifies a file.

 

Thanks.

 

Frank Hahn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...