Jump to content

No preview for canon cr2 files during "import" dialog


Recommended Posts

Hello from Vienna!


When I want to add new pictures to a katalog I do net get any preview pictures of my canon cr2 pictures any more. In Windows explorer I canot see any preview Pictures or Thubnails as symbols for my raw pictures.

My Windows 10 has the latest updates! I even installed the latest codex "RawImageExtension_2.1.30391".


Probably You have the solution!


Thank You



Link to comment
Share on other sites

Hello, thank you for your reaction. I have the latest release of Server an Client - "Homeedition"

It is interrsting: when I put in the windows explorer my mouse on the symbol of the file, press the left mousebutton and move the mouse I can see the picture!

Thank you again

Link to comment
Share on other sites

Hi Daria

I use the latest release of the Server! I do not know, if it is a windows problem.

If I select the symbol of a picture with the left mouse button and move the mouse with held button I can see the picture.

I hane installed the latest version of windows an tried to insrall te latest RawImageExtension_2.1.30391.

The result is still poor!

Probably you have seen this behaviour before.

Thank you for trying to find a solution,


Carolus Stigler

Link to comment
Share on other sites

Hi Daria,

so it has taken a longer time to send you my answer, but I have tried a lot of things to get rid of this issue.


The Issue:

The Thumbnails appear when I open a folder wit raw pictures - but they disappear after a short time - no Preview (please see video)

When I select a picture in the Windows Explorer (does not matter - right or left mouse button) and drag it I can see the thumbnail (please see video)

If I move my mouse over a picture I get the exif Information of the picture. The same in the details in the Windows Explorer right side - but no Thumbnail or preview! So I think that Windows can read the raw pictures - but not display them as a normal preview or Thumbnail.

Import to daminion Client - no preview of the picture in the "selection Window" (please see picture)

I cannot say when this strange behaviour started! But I did not install a new Software since it worked fine. Just the usual updates. Nothing really new!


What I have tried already:

  • Install / Uninstall / ReInstall the Raw Extension
  • Uninstall / Reinstall Nvidia Driver
  • Cleaning Registry with CCleaner in between uninstall an reinstall
  • Cleaning of the Thumbnail Cache and other cache of the computer
  • Creating more Thumbnail Cache with the Key in the Registry
  • Options in Windows-Eplorer (see picture)

I included pictures showing the release of the involved software. As a Viewer I use "Faststone" - In Faststone I can see all the raw file normally.


Probably You know or have an idea how to solve this issue ! Thank you for your help






Link to comment
Share on other sites

Hi Lupus, 


Thank you for the video! I thought the issue was with the thumbnails in Daminion. In the import dialog windows, Daminion gets the thumbs from windows explorer, and after the import - from the files. 


Not sure what the issue with Windows explorer can be - have you tried the following approach: 


Click Control Panel > Type Folder in Control Panel Search box > Click File Explorer Options > View tab > Uncheck Always show icons, never thumbnails (If this is already unchecked, check it and OK..Then go back again and uncheck it and OK?


Link to comment
Share on other sites


Hi Daria and all of you!


I solved the problem! Probably someone else can use this information in the future!


I have found out, that my Windows Explorer has the same behaviour with or without the Microsoft Raw Image Extension. Seeing Thumbnails for a few seconds, then disappearing. So I deinstalled it!


Then I searched my registry for .cr2 and I found out, that an old Microsoft Camera Codec Pack was still on my computer - finding keys showing this in the registry.

I searched the Internet how to get rid of this "old" Microsoft Camera Codec Pack.

During my search I found the following page:


Here I downloaded the Windows driver and after installation it worked! I installed this package with Raw Image Extension still uninstalled!

It's funny but I have tried to install this canon codec Pack 1.11 before, but I always got the message, that it is not working with this Release of Windows. So I think, it is not the release of Windows but the Raw Image Extension.


I have not tried to get this codex from somewhere else, but I think you can download it from other locations, too!


I still do not know where this problem came from originally!


So I am happy again!!!

Thank You to all of You



  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...