Jump to content

Comment Field problem? (1582)


Paul Barrett
 Share

Recommended Posts

Hi Folks

 

Question re Comments fields.

 

I imported some images for which the owner had placed some entries in the comments field in Windows (scary) to help me tag and date the files after I got them into Daminion. But after import, the comments did not show up in Daminion's comment field.

 

I looked in the metadata and the comments were present, but in the EXIF field XP Comment

Fair enough, Daminion uses a different field to Windows. So I need to copy the contents of the XP Comment field to whatever field Daminion uses. Fine, I can do that in ExifTool. I just need to know the target field name. So, on one of the images I entered a Daminion Comment and synced the file. But when I examined the metadata again, the Daminion comment had not appeared. I forced a write of the metadata to file just to be sure, but it made no difference. I tried another file - no difference.

 

  1. Does this mean that the Daminion Comment field is not written to the metadata but only to the catalog?
  2. If not, what field is Daminion supposed to write to?
  3. And if it isn't, any suggestions on what do I do next please?

Regards

 

- Paul

Link to comment
Share on other sites

Hello,

Daminion reads and writes the Tag Exif:UserComment - if the option in the Preferences "Add compatibility with Windows Explorer..." is ON.

The panorama software I use does also write the same tag.

 

But if this option is OFF - Daminion doesn't write any comment to the file.

If there is already the tag Exif:UserComment existing Daminion reads this tag but any adjustment of the comment made in Daminion will be in the catalog not in the file.

This is inconsistent. There should be a XMP tag in this case.

 

Regards, Uwe

Link to comment
Share on other sites

Hello,

Daminion reads and writes the Tag Exif:UserComment. The panorama software I use does also write the same tag.

Regards, Uwe

 

Thanks Uwe

 

OK so i will copy the data over to that field using ExifTool.

 

Daria - if you're following this thread, that leaves me with an issue that on the two sample files I have tried so far, when I enter comments in Daminion, they are not being written to the metadata. How do I fix that please?

 

- Paul

Link to comment
Share on other sites

But if this option is OFF - Daminion doesn't write any comment to the file.

If there is already the tag Exif:UserComment existing Daminion reads this tag but any adjustment of the comment made in Daminion will be in the catalog not in the file.

This is inconsistent. There should be a XMP tag in this case.

 

Regards, Uwe

 

OK, thanks Uwe, that option was turned off. The tags were written as soon as I turned it on.

 

And I agree about the inconsistency

 

- Paul

 

 

Link to comment
Share on other sites

  • 7 months later...
Daminion reads and writes the Tag Exif:UserComment - if the option in the Preferences "Add compatibility with Windows Explorer..." is ON.

Was the option "Add compatibility with Windows Explorer..." removed with a recent build? I don't see it in Build 1717 and discovered accidentally, that the content of the Daminion "Comment" tag is no longer written to the metadata. It was synchronized until April 2017. Not sure, which Build I was using at that time. Very likely the synchronization of the comment tag did work unti Build 1592.

 

 

 

Link to comment
Share on other sites

in the Server version build 1715:

Uwe, I was referring to the standalone client. Until April this year, Daminion automatically synchronized the comment tags.

 

I just verified in Build 1717, even Actions->Write Tags to file does not write the comment into the JPG, according to the report in ExifTool (Show All Metadata). When I import the image into a newly created catalog, I don't see the comment neither.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...