Jump to content

Installing Server on Local PC


Paul Barrett
 Share

Recommended Posts

Hi folks

 

I have been using Daminion standalone for a few months now. My images library is stored on a Synology NAS drive so I can use Photo Station to give me web access,

 

I believe that by installing the server version I can set up file / folder watching service to auto-update the catalog for changes made in Photo Station.

 

Al the help inho is about setting up a new catalog not converting an existing.

 

Has anyone else dine this? If so can you offer any advice please?

 

Trgards

 

Pauk

Link to comment
Share on other sites

Hello Paul,

if you don't want to convert the existing local catalog you have to import the files on the NAS to a new shared catalog. There are some information for you to decide which schema is the best for you: https://daminion.net/tutorials/selecting-the-right-file-storage-scheme-for-daminion-server

I use schema A even if other are faster regarding the access to the files but this is ok for me. The catalog and the thumbnails are on internal SSD.

Regards, Uwe

Link to comment
Share on other sites

OK I tried to create a new shared catalog but I have problems.

 

The picture shows the issue. I am no techie so most of this is way over my head. They say a picture paints a thousand words and since I have no words to describe the situation, here's the picture:

 

post-3427-0-22010500-1482050890_thumb.png

 

At step 7 I began to realise that there might be some sort of permissions issue but I am at a loss to know what to do to fix it

 

I'd welcome any feedback

 

Season's greetings to you all

 

- Paul

Link to comment
Share on other sites

Update:

 

Uwe very kindly got on a TeamViewer session with me this morning and looked at the problem.

 

It appears to be related to postgres, which has a connection problem. Uwe is successfully running a very similar system to mine, with two key differences:

 

1. He is running Windows 10 Pro and I am running Home. Home seems to have a problem running the required services.

 

2. He has overlaid a later version of postgres.

 

There was also an issue when we tried to do a network rather than local account type. I login to my PC with a windows account not a local one, and my windows account name is my email address. It appeared that the @ sign in my user account name caused the installation to choke. We thought this was because @ was signifying a domain name to the program, whewreas in Win 10 Home there is no concept of joining a domain.

 

We (sorry, he) were unable to fix the issue so I will report it to Daminion and see if they can resolve it as it is way beyond my skill level.

 

- Paul

Link to comment
Share on other sites

Alexey fixed it! clapping.gifdrinks.gifgood.gifpardon.gif

 

The issue was that the username and password of the local PC user account and the Synology user account have to be same.. There was an issue using my default PC user account because that is linked to my Microsoft account via my email address so he created a 'daminion' user on both the PC and Synology and assigned them the same password. Problem solved.

 

This issue seems to be unique to Windows 10 Home users.

 

Of course, now it is working I will have some questions relating to the differences between standalone and server versions. Watch this space.....

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...