Jump to content

How to: Daminion Server and an existing Postgre database


lintujuh
 Share

Recommended Posts

I have installed another software (OpenERP) earlier in my computer that also uses PostgreSQL database. I have tried to install Daminion Server and set it up with no success.

 

The installation goes without errors, but after the installation Daminion Server is not started. I have to change in the Server Administration Console the database username/password to the existing db user/pwd and then I can start the server. When I after that try to open a shared catalog in my computer I gen an error "Object reference not set to an instance of an object." and in the log there is error database doesn't exist (3D000).

 

I have tried to uninstall and reinstall the software and tried to reboot the system in between but nothing has worked. I have also tried to run the installation process several times like Exterminador suggested in his post (https://daminion.net/user-forum/index.php?/topic/287-some-findings-with-daminion-089477/page__view__findpost__p__1112). Now I don't know what to do next.

 

I tried also specify the username/password during the install (option typical), but still when I started the Server Admin Console and looked at the settings, the username was 'postgres' not the one I specified.

Link to comment
Share on other sites

I've downloaded OpenERP and install it on our testing PC. I was able to reproduce the problem above if the Daminion Server was launched with Log on As LocalSystem. For some reason the LocalSystem user doesn't have enough privileges to launch services after OpenERP installation.

 

Please open Administrative Tools > Service, navigate to Daminion Server Service, and change Log On As to another user. Or you can do it during the fresh Daminion Server Installation.

 

Note: after changing the login/password fir PostgreSQL press Test button to verify your connection with PostgreSQL service.

 

Please inform me if this will helps.

Link to comment
Share on other sites

Unfortunately not. I also rebooted my laptop. Database and Daminion Server were started at boot, but when I tried to open a shared catalog I got the same error.

 

But I got it working when I started pgAdmin and noticed, that there are two database servers running at ports 5432 (OpenERP) and 5433 (Daminion). I checked the settings in Daminion Server Console and there the connection was to the first server (5432). When I changed the username/password to Daminion defaults and changed the port number to 5433 it started to work. I think there is some discontinuity between installation and server setting defaults as I didn't touch the port number. If it is difficult to automate it should be at least pointed out to users to check if they already have PostgreSQL running in their computer before installing Daminion.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...