Jump to content

Question to "Add compatibilty"


Herb
 Share

Recommended Posts

Hello,

 

I am working with Daminion 4.0.1268 and I have some questions to option "add compatibilty".

 

-> Edit -> Preferences -> Writing Metadata -> Add compatibility with Explorer....

is unchecked.

I created a new catalog and imported 2 JPG images for test.

Action "Show all metadata" displayed all metadata and both images had no IPTC and no XMP tag.

Then I assigned 1 keyword "keyword1" to 1 image and I wrote metadata into file. (Auto-Sync is off).

 

Now "Show all metadata" displayed

- xmp-tags Subject and Hierarchical Subject: both contained "keyword1"

- iptc-tag Keywords: it contained also "keyword1"

 

Because "add compatibility" is unchecked I had expected that no IPTC tags/group will be created at all.

 

What did I wrong? or what have I overseen or what do I misunderstand?

Thanks in advance

Herb

Link to comment
Share on other sites

I made a quick test and was slightly disappointed. With compatibility off, Daminion writes quite many tags to IPTC and EXIF. With compatibility on, it writes even more.

 

Personally, I would rather not have author, description and copyright tags in EXIF data, especially when using non-ascii characters (my language uses some). As far as I know, UTF-8 is not officially supported in EXIF and some programs might show the characters scrambled.

Link to comment
Share on other sites

When "Add compatibility" option is turned off Daminion writes tags only to XMP using Adobe XMP Toolkit library. However, this library can also updates some IPTC fields when saving/updating XMP. This is not bad as you think, because this allows to sync IPTC and XMP values, and EXIF/IPTC block size is tiny in comparison to an image size.

 

And anyway XMP info is prefered when reading most of the descriptions (unlike camera info tags).

 

BTW Author and Keywords are encoded in EXIF block as UTF8.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...