Jump to content

No thumbnails after upgrade to 3.4


rsmith1
 Share

Recommended Posts

I recently upgraded Daminion from 3.0 to 3.4 (the regular commercial download version, not one of the pre-release builds), and I no longer have any thumbnails showing on the screen, nor can I see any files in the viewer. My first thought was a permissions problem between my workstation and NAS, but I imported some brand new images from my local disk, and the same problem occurs. I used the Server Administration app to move the thumbnails location to a folder where I directly assigned permissions to the local user under which Daminion Server is running. No thumbnail files are ever created. I then looked at the server logs where I found this message, which seems to imply that something being read from the PostgresSQL DB is not what is expected:

 

2014-12-12 11:33:59,921 [sTP SmartThreadPool Thread #0] WARN  PicaJet.Daminion.Service.Utils.GetThumbnailServiceCommandV2 [(null)] - System.InvalidCastException: Specified cast is not valid.
  at Npgsql.NpgsqlDataReader.GetInt64(Int32 i) in C:\projects\Npgsql2\src\Npgsql\NpgsqlDataReader.cs:line 301
  at PicaJet.Daminion.Service.Utils.RenderHelper.SelectDelegate(DbDataReader reader) in c:\DaminionAuto\Code\Service.Utils.Uni\Helper\RenderHelper.cs:line 221
  at PicaJet.Daminion.Service.DbCommandHelper.GetUniqueValue[T](IDbCommand command, SelectDelegate selectDelegate) in c:\DaminionAuto\Code\Service.DB\DbCommandHelper.cs:line 157
  at PicaJet.Daminion.Service.Utils.RenderHelper.GetFileValues(DbConnection connection) in c:\DaminionAuto\Code\Service.Utils.Uni\Helper\RenderHelper.cs:line 195
  at PicaJet.Daminion.Service.Utils.RenderHelper.Render(String filePath, RenderInfo[] renders, DbConnection connection) in c:\DaminionAuto\Code\Service.Utils.Uni\Helper\RenderHelper.cs:line 42
  at PicaJet.Daminion.Service.Utils.GetThumbnailServiceCommandV2.GenerateCacheFileClass.GenerateCacheFileAndSaveStack(DbConnection connection) in c:\DaminionAuto\Code\Service.Utils.Uni\Command\GetThumbnailServiceCommandV2.cs:line 325
  at PicaJet.Daminion.Service.Utils.GetThumbnailServiceCommandV2.Treat(DbConnection connection) in c:\DaminionAuto\Code\Service.Utils.Uni\Command\GetThumbnailServiceCommandV2.cs:line 119

 

Could some kind of necessary update to the DB schema have been missed? In any case, I hope that someone can help me resolve this problem.

 

Randy

Link to comment
Share on other sites

The problem can be solved by the next way:

 

1. Backup your shared catalog via the Daminion Server Admin panel (Administration\Catalogs...\Actions\Backup)

2. Uninstall the existing PostgreSQL 9.0 version

3. Install the new PostgreSQL 9.3.5 version.

4. Install the Daminion Server 3.5 (1119) version.

5. Launch the Daminion Server Admin panel and restore your catalog from the backup that you did in the step #1. (Administration\Catalogs...\Actions\Restore)

 

It should works.

 

We can also do this for you remotelly. Please let me know.

Link to comment
Share on other sites

That fixed it, Murat. Thanks for the instructions. Was the problem the PostgreSQL version or something else? BTW, the Daminion Server version you linked to was 3.4.1119, but I assume that is just a simple typo. Also, I used PostgreSQL 9.3.5 as you said, even though 9.4.0 is out (.0 versions make me nervous, even when I write the software :wink: ).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...