Jump to content

[1037 on Win7] 2 possible bugs


rahulvarma
 Share

Recommended Posts

I've noticed a couple of possible bugs-- perhaps I am not using Daminion correctly.

 

1. I cannot get Daminion to read the photograph's ISO-- it can read and display the shutter speed and aperture correctly. When I check the detailed metadata the ISO is available, but I just cannot get it to show on the thumbnail or full screen of an image.

 

2. When i make a change to properties in the Properties pane (rating or color label) it doesn't update the file, even if I re-sync. When I make these changes in the image thumbnail it works OK and, in fact, updates the info in the Properties pane. When I change the rating in the Properties pane a small asterisk appears next to the word Rating, but not when I make the change in the Thumbnail.

 

 

Thanks

Link to comment
Share on other sites

1. I cannot get Daminion to read the photograph's ISO-- it can read and display the shutter speed and aperture correctly. When I check the detailed metadata the ISO is available, but I just cannot get it to show on the thumbnail or full screen of an image.

 

Can you please send us your image file for detailed analyzing? Perhaps the ISO info was hidden somewhere in the Maker Notes...

Link to comment
Share on other sites

After playing around with my image files and ExifTool I realize that perhaps this is what is going on:

some versions of Nikon software (not all, though, it would appear) are writing ISO info to MakerNotes and not to EXIF. Some other subsequent programs have stripped this info from MakerNotes and written them to EXIF-- in these cases Daminion is able to see and report ISO; in cases where the particular Nikon s/w did not write the ISO to EXIF, and the image was not processed by any tool that wrote to EXIF, Daminion does not see ISO, even if info is available in MakerNotes.

 

In one test image I was able to use ExifTools to replace Exif:ISO with Nikon:ISO (i.e. ISO from MakerNotes) and then Daminion was able to see the ISO data. However, I had to drop image from Daminion catalog and add it back again for it to work; re-scanning and re-linking did not work.

 

Possible solutions:

1. use Exiftools to replace ISO with ISO from MakerNotes and re-create catalog in Daminion;

2. Daminion adds a feature to do above (read ISO and perhaps other data from MakerNotes, and then maybe even add to EXIF)

 

Thoughts?

 

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...