Jump to content

Access to the server from another machine on the network


pgrondin
 Share

Recommended Posts

After installing Server version 0.8.8.445 everything seems to be working on the server machine (Windows 7 Professional SP1 62 bit).

 

I have added the following programs to the Firewall exception list:

Daminion

Daminion Server

Postgres.exe

 

From the laptop (Windows XP SP3) I can only open the shared catalog if I disable the Windows 7 Firewall on the server machine or:

 

If, on the server machine, I go into Windows firewall - Advanced Settings - Inbound Rules" , I can open a shared catalog if I set the following options.

 

Advanced Tab

- Allow Edge Traversal

 

OR

 

Scope Tab

Local IP Addresses - I enter the full range of addresses which my router DHCP may assign.

 

All other settings are at default.

 

Seems a bit cumbersome. When I look at the default settings in Windows Firewall advanced settings I do not see anything that would appear to block my laptop access, but then I am not a networking guru. I would have thought that "Any IP address" would accept everything, but it only seems to work if I give it my actual network IP's.

 

With either of the above settings, I have access to the catalog from all users on the laptop, and can update tags.

Link to comment
Share on other sites

On Windows 7 you can do the following:

- Open Windows Firewall

- Click "Allow a program or a feature through Windows Firewall" menu option

- Click "Add Another Program" button

- Click "Browse..." button

- Locate the file below:

"C:\Program Files (x86)\Daminion Software\Daminion Server\Daminion.Server.exe" for Windows 64 bit

or

"C:\Program Files\Daminion Software\Daminion Server\Daminion.Server.exe" for Windows 32 bit

 

After that you should be able to connect to Daminion Server from remote computers.

Link to comment
Share on other sites

I agree, that is the way it should work, but did not, hence the dig deeper approach. Your instructions were essentially what I did to get as far as:

 

I have added the following programs to the Firewall exception list:

Daminion

Daminion Server

Postgres.exe

 

From the laptop (Windows XP SP3) I can only open the shared catalog if I disable the Windows 7 Firewall on the server machine or:

 

After that in my original post is what I had to do to get it to actually work. I have no idea whatsoever why I had to do that. Windows at times is a very strange beast.

Link to comment
Share on other sites

Since I believe firewalls are supposed to run on the router I am not really familar with Windows Voodoo nor with desktop firewalls. But what I did to allow connections to the Daminion server was that I opened the TCP inbound ports 8082 and 8084 on the machine that is running the server. Maybe this helps?

Link to comment
Share on other sites

Hello,

 

Open the firewall, go to advanced settings. On the left select "inbound rules" and on the right "new rule".

Now select "ruletype" "port" and then "next"

Check the "TCP" radiobox and enter "8082, 8084" in the textbox. "next"

Check the "allow connection" radiobox "next"

Check all checkboxes except "public" then "next"

Enter a meaningfull name like "Daminion" and hit "done"

 

I am working with a german version so the exact wording might vary from what I wrote by translating the german entries. But I hope this gives you the idea and will work for you too.

 

However from what I read Murat plans a new release next week with an improved installer. So the firewall rules might already get added with the new version!?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...