Jump to content

Bug? Exporting JPEG, place metadata problem


deebee
 Share

Recommended Posts

Hi,

 

I'm a new user of Daminion, and have had a good experience so far. However, today I have a problem exporting TIF images as JPEGs with some (long) metadata.

 

An example of the report I get:

 

#452 : P4110355_DxO.tif

Specified argument was out of the range of valid values.

Parameter name: USA|Utah|Arches National Park : value should be splitted with '|' char 4 times according to the Place specification

at PicaJet.Daminion.MediaProcessing.CatalogTagCollectionItem.SetComplexValue(MappingRule rule, String rawComplexValue)

at PicaJet.Daminion.MediaProcessing.CatalogTagCollection.WriteValuesToMetaTags(Boolean includeSynonyms, Boolean flattenKeywords)

at PicaJet.Daminion.ImageProcessing.ImageProcessor.ApplyMetadata(Object _ieImage, MediaInfo mediaInfo, ActionSetParams _params, IEnumerable`1 catalogTags) in c:\DaminionAuto\Code\MediaProcessor\ImageProcessor\ImageProcessor.cs:line 1611

at PicaJet.Daminion.MediaProcessing.TransformationEngine.TransformFile(MediaProcessingEngine engine, String fileRef, ActionSetParams _params, RotateAngle rotateAngle, IEnumerable`1 catalogTags, GetParamValue getWatermark)

 

The image has the following place metadata:

USA

Utah

Arches National Park

Delicate Arch

 

The error happens on all images with the above metadata, but curiously other images export without any problems even though they have similar metadata such as:

USA

Utah

Canyonlands National Park

Island in the sky

 

Is this a bug, or am I 'overloading' the metadata?

 

To be honest, the export is purely for upload to a website and so I don't actually need the metadata, so if a quick fix is to disable metadata export, I would be happy to be shown how.

 

Thanks

Dee

Link to comment
Share on other sites

Thanks for the prompt reply, Murat.

 

I have tried the same operation in 1070 and get the same error. However, your temporary workaround got me up and running for the moment.

 

I will send links to a sample file and my catalog for further investigation.

 

Dee

Link to comment
Share on other sites

It seems that the "Arches National Park" was on the level of Location and then moved to one level up using the Move Out command, right?

 

I suggest you to do the following steps to fix the issue:

- Rename the "Arches National Park" to "Arches National Park - 2"

- Create a new "Arches National Park" below the USA\Utah

- Assign all images from the "Arches National Park - 2" to the newly created "Arches National Park"

 

It should works then.

 

We'll disable the Move Out command for the Place tag in the next Daminion builds.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...