Jump to content

[all versions up to 951] Crash due to memory leak in thumbnail view


_noel_
 Share

Recommended Posts

I reproducably get crashes with Daminion while extensive scrolling in the thumbnail view:

 

Workflow:

  • my display has a resolution of 2560x1600 pixels, I've configured my view to see three rows and five columns of thumbs (->15 thumbs per page)
  • scrolling through the thumbs (80% JPGs, 20% DNGs) with the keyboard (arrow key) or with the mouse wheel for about 4000 to 6000 thumbs
  • the mem leak occures with or without "Color Management" enabled
  • the mem leak occures with or without properties window enabled

Error: Daminion crashes with different errors, two of them attached below.

 

post-925-0-67537900-1390665432_thumb.png

 

CrashScollingThroughThumbs.txt

 

 

The behaviour is reproducable.

 

Regards

 

Eberhard

Link to comment
Share on other sites

Unfortunatelly we tried to reproduce this issue on several computers in our local network but without luck. Does it possible to give me a remote access to your PC?

 

Did you work with Daminion local or shared catalogs?

 

Could you please send me your Daminion Standalone settings (Ctrl + F12, then locate and send me the "1.0" folder)

Link to comment
Share on other sites

Unfortunatelly we tried to reproduce this issue on several computers in our local network but without luck. Does it possible to give me a remote access to your PC?

 

Did you work with Daminion local or shared catalogs?

 

Could you please send me your Daminion Standalone settings (Ctrl + F12, then locate and send me the "1.0" folder)

 

You can find may settings here.

I'm using Daminion Standalone.

You can find the "1.0" folder in the same Dropbox folder.

Remote access to my PC will be difficult, what tool or method would you prefer ?

Link to comment
Share on other sites

Unfortunately I can't reproduce the issue on several of our computers.

 

Could you please try to reproduce the issue on a small portion of images selected by more narrow filter:

- JPEG images only with sRGB, and then JPEG images with another color profile?

 

JPGs with sRGB is no problem, JPGs with other profile ? .... I think, mine are 99,9% with sRGB ... I will try to narrow the issue ...

Is there anything I should trace or log ? I will try to run windows perfmon in parallel, so we can get some "curves" in the next days ...

 

Regards

Eberhard

Link to comment
Share on other sites

JPGs with sRGB is no problem, JPGs with other profile ? .... I think, mine are 99,9% with sRGB ... I will try to narrow the issue ...

Is there anything I should trace or log ? I will try to run windows perfmon in parallel, so we can get some "curves" in the next days ...

 

Logs will be helpful to locate certain files. But I'd like to try to determine before whether this depends from images of a certain format or certain color profile/color space.

 

You can launch the Daminion with -log_enable parameter but this will log only some actions on the Client. In the Daminion Server log writing is enabled permanently.

 

 

BTW do you have CMYK images? Unfortunately we didn't extract Color space from images now (only Color Profiles) but probably we should do this.

Link to comment
Share on other sites

  • 2 weeks later...

My suspicious that this might be related to unmanaged code related to image processing part of the Daminion. Don't know whether yourkit allows to track this. But I'll try it. Thanks for the suggestion

 

yourkit only works with managed code, unmanaged code & leaks ? ... ugly :-( ... we use Intel inspector here, but it's not so easy

 

Regards

Eberhard

Link to comment
Share on other sites

Eberhard, thanks for the additional info. To eliminate dependence from certain images params could you please:

1. Create a new test catalog using 961 build

2. Create a new test folder and put there 4000 copies of this test image.

3. Try to reproduce the issue again

 

  • Duplicated the image 12K times and imported to new catalog with newest daminion version 961, German UI
  • closed Daminion
  • opened catalog, fullscreen 256x1600, biggest thumbs in 3 rows to 4 columns, hitting <PageDown> every second
  • after about 4K thumbs -> crash, see screenshot and error message

I'll try to narrow down the problem ... switch German UI to English ? ... any other ideas ?

 

BTW: I'm using "Faststone Codec Pack" (Faststone), is this important ?

 

Regards

Eberhard

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...