Jump to content

Cant connect to server


franky68
 Share

Recommended Posts

Hello,

 

maybe I am missing something...

 

I installed Daminion server and am trying to use it. To do this I start the regular Daminion, select "Open shared catalog" and create a connection. When clicking "Open" all I get is sometimes an error message sometimes nothing happens at all.

 

- I tried the connection from my desktop and my laptop.

- On my desktop I used 192.168.1.51 (lan ip) and 127.0.0.1 (loopback)

- I checked the port and database name: both are identical in the connection and server settings

- I did a full reboot on the desktop hosting the database

- I tried a telnet to that port which immediately dies with "connection abort"

 

Here is the error message I get eventhough its probably not very helpfull to you (and german):

 

Informationen über das Aufrufen von JIT-Debuggen
anstelle dieses Dialogfelds finden Sie am Ende dieser Meldung.

************** Ausnahmetext **************
System.ServiceModel.FaultException`1[system.ServiceModel.ExceptionDetail]: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. (Fehlerdetail ist gleich Ein ExceptionDetail, vermutlich erstellt durch IncludeExceptionDetailInFaults=TRUE, mit dem Wert:
System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
  bei PicaJet.Daminion.Service.WCF.CatalogService.GetNamespaceItems(Int32 pageIndex, Int32 pageSize) in c:\DaminionAuto\Code\Server.WCF\CatalogService.cs:Zeile 185.
  bei SyncInvokeGetNamespaceItems(Object , Object[] , Object[] )
  bei System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
  bei System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
  bei System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
  bei System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc)
  bei System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage3(MessageRpc& rpc)
  bei System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage2(MessageRpc& r...).


************** Geladene Assemblys **************
mscorlib
   Assembly-Version: 2.0.0.0.
   Win32-Version: 2.0.50727.5448 (Win7SP1GDR.050727-5400).
   CodeBase: file:///S:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll.
----------------------------------------
mscorlib.resources
   Assembly-Version: 2.0.0.0.
   Win32-Version: 2.0.50727.5448 (Win7SP1GDR.050727-5400).
   CodeBase: file:///S:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll.
----------------------------------------
Daminion
   Assembly-Version: 0.8.6.419.
   Win32-Version: 0.8.6.419.
   CodeBase: file:///C:/Programme/Daminion%20Software/Daminion/Daminion.exe.
----------------------------------------
PicaJet.Daminion.ClientCommon
   Assembly-Version: 0.8.6.419.
   Win32-Version: 0.8.6.419.
   CodeBase: file:///C:/Programme/Daminion%20Software/Daminion/PicaJet.Daminion.ClientCommon.DLL.
----------------------------------------

Edited by Murat Korkmazov
I've a bit truncated the log for the better formatting.
Link to comment
Share on other sites

Frank, thanks for the bug-report!

 

- Did you change the port and database name?

- Could you please update your local Daminion version to 434 build and try again?

- Could you please send me the server log folder:

c:\Program Files\Daminion Software\Daminion Server\Logs

Link to comment
Share on other sites

Thanks for the pointer to the logfile. I already located the problem.

 

There was a problem with the password somewhere so the Daminion server could not connect to the PostgeSQL server. I initially did not check that connection since the Daminion Server said "Running" so I assumed everything behind it would be ok.

 

Maybe the Daminion server should issue a an error dialog when it cant connect to PostgeSQL for whatever reason. This is Windows after all and you never can know if a daemon silently died ;)

 

Anyway I was just importing my first images into the ServerCatalog. Ill post my next problem in another thread ;)

Link to comment
Share on other sites

Could you please describe what sort of the problem was there

 

I am not quite sure about that and have not yet had time to try to reproduce it. Thats why I did not describe in more detail. But I changed the password for the PostgreSQL default user. I also used the same password for the Daminion Server setup.

 

and how did you solve it?

 

I uninstalled Daminion Server and PostgeSQL. When PostgeSQL was re-installed it complained that the default user was already existent so I entered some custom account.

 

As said this is a bit unclear. I guess Daminion could not handle the changed PostgeSQL password but have not yet verified and I am not sure what changed since it did not seem like the initial user was deleted/reset.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...