Jump to content

Exiftool and filenames with unicode characters


Herb
 Share

Recommended Posts

Hello,

 

I am working with Daminion standalone version 1.0.0 build 779.

 

Daminion supports unicode characters in tag-values and also in filenames.

This is great for me. Thanks.

 

But reading all tags from a file with Exiftool does not work in case of the filename contains an unicode character.

Daminion does not hang or break, but nothing is displayed.

 

This is clear to me, because the perl layer of the windows Exiftool.exe does only support ASCII characters in filenames (as described in Exiftool restrictions).

 

So please use the windows short-filename in this case when starting Exiftool.

I am sure it will work. Thanks in advance.

 

Best regards

Herb

Link to comment
Share on other sites

  • 2 months later...

Hello,

 

On one hand I want to inform you that XnViewMP had the identical problem using ExifTool.

They solved the problem using only the 'file-short-name' launching ExifTool.

 

On the other hand I ask you to implement this feature in one of the next versions. I now use 1.0.0.870.

Thanks in advance.

 

Best regards

Herb

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...