Jump to content

Server Data Location


Recommended Posts

I installed Daminion Server today but I don't like where the data is located

 

I want the PostgreSQL Database to be on Drive G: not on C: By default it was installed at C:\ProgramData\PostgreSQL\Data. I'm not talking about putting the uploaded files folder on G: (I've already done that.)

 

On a related point, I keep all of my OS library files on G: but during the Server install a new user, "postgres", was created under C:\Users\postgres. I also want this under G:\Users\postgres. I guess the installer couldn't detect that I had moved my User files to G: when it created the new user for the SQL server.

 

In other words, the servers themselves can be on C: but I want all of the data for both the Daminion and SQL servers stored on G:

 

Can anyone point me to instructions on how to do this? I've looked through the posts here but don't see anything specific enough to help.

Link to post
Share on other sites

- Stop PostgreSQL service

- Uninstall PostgreSQL

- Rename the PostgreSQL Database location:

C:\ProgramData\PostgreSQL\Data

 

- Open the "Computer Management" window, locate Users tab and remove the "postgres" user

 

- Launch the Daminion Server Installation again

- Specify "Custom" setup type (instead of the "Standard" one)

- Specify a new location for the PostgreSQL installation

- Follow the further installation steps to finish the Daminion Server installation

 

Hope this helps

Link to post
Share on other sites

I was able to move the existing database to a new drive using these steps:

 

1 - Stop the Postgres and Daminion Server services using Administrative Tools > Services control panel (can also use the Daminion Server Administration app to stop Daminion Server).

 

2 - Move C:\ProgramData\PostgreSQL\Data\*.* to the destination directory (ex. P:\pgdata\)

 

3 - Ensure that the local user postgres has full control rights to the destination directory.

 

4 - Open the Registry Editor (regedit.exe)

 

5 - Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\postgresql-9.0

 

- Modify ImagePath:

From: C:/Program Files (x86)/PostgreSQL/bin/pg_ctl.exe runservice -N "postgresql-9.0" -D "C:/ProgramData/PostgreSQL/Data" -w

To: C:/Program Files (x86)/PostgreSQL/bin/pg_ctl.exe runservice -N "postgresql-9.0" -D "P:/pgdata" -w (where P:/pgdata = your new PostgreSQL directory)

 

- NB: Remove the (x86) if running on a 32-bit machine

 

6 - Restart the Postgres and Daminion Server services using Administrative Tools > Services control panel (can also use the Daminion Server Administration app to start Daminion Server).

 

Daminion seems to be working with the database fine, and I can still work with the database using the PG Admin tools, so everything seems to be OK.

  • Upvote 1
Link to post
Share on other sites

*snip*

Specify "Custom" setup type (instead of the "Standard" one)

*snip*

Thanks Murat. I should have known that all I had to do was a "Custom Install". It worked fine.

 

Thanks to you also Randall. I appreciate your reply. I would have tried your steps if Murat's suggestion hadn't of worked.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...